Security Notices

Buffalo EU is aware of the importance of security and the vulnerabilities that come up and investigates its product line regularly. We care for our customers and release new updates where necessary. Buffalo recommends downloading the latest versions of our firmware.

Check the list of identified vulnerabilities and products affected:


Description of vulnerability and updates

Affected Products

January 11, 2018

CPU Vulnerability

WSH5610 Series, WS5000 Series

December 12, 2017


No products affected

December 12, 2017

Initiates file downloadSamba-VulnerabilityCVE-2017-14746 , CVE-2017-15275)

TeraStation™, LinkStation™, AirStation™

November 2017


Wireless Routers, USB adapters

June 2, 2017

Samba vulnerability CVE-2017-7494

TeraStation™, LinkStation™, AirStation™